English Chinese (Simplified) (zh_CN)
Distribution-wide Changes
Update comps to use Python 3
Multiple package groups have been updated to use [package]`python3` packages instead of [package]`python2`. The list of groups is:
[package]`python-classroom`
[package]`engineering-and-scientific`
[package]`development-libs`
[package]`cloud-management`
[package]`font-design`
[package]`mysql`
[package]`robotics-suite`
[package]`authoring-and-publishing`
[package]`electronic-lab`
Also, the [package]`python-web` package group has been removed from comps.
ZRAM support for ARM images
Previous releases of Fedora for ARM (`Aarch64`) systems enabled a small amount of swap space by default. This was generally a good thing, however in some cases using swap on ARM can cause problems such as heavy wear on SD cards due to excess use of wear leveling. Fedora 29 enables ZRAM in order to mitigate this and enable more memory on ARM single-board computers (SBCs) by compressing a part of the RAM and using it as a swap space. This provides better performance and reliability on such devices, which in turn provides better user experience. ZRAM is enabled on all ARM images by default.
Discontinue PPC64
Fedora 29 drops support for big endian IBM POWER (`ppc64`) systems. This change comes after big-endian ppc64 systems have been supported in a "maintenance only" mode for several years, and is largely caused by upstream focus on little endian `ppc64le`. For more detailed justification behind this change, see the link:++https://lists.fedoraproject.org/archives/list/ppc@lists.fedoraproject.org/message/D6G5RQUTRYGZ5Y4XIPMADMUSH2PTZDO4/++[mailing list announcement].
Update i686 architectural baseline to include SSE2
In previous releases, `i686` RPM packages were built in a way that was compatible with certain very old processors such as Intel Pentium III. The only addition over the i686/Pentium Pro baseline is a requirement to support long NOPs, for Intel CET. However, the majority of `i686` package installations is actually on `x86_64` systems as multi-lib RPMs. Furthermore, there are link:++https://lists.fedoraproject.org/archives/list/x86@lists.fedoraproject.org/thread/ZHV6I4IEO7GRYAZ4TUMO5VH2ZHLCNJZQ/++[reports that the i686 kernel does not run stable on old hardware which is not `x86_64` capable].
Fedora 29 changes build requirements for `i686` packages in such a way that they require the instruction set architecture (ISA) of early `x86_64` CPUs. Specifically, the following changes are made to 32-bit packages to optimize them for use on current `x86_64` systems: