English Italian
All new modules and all the core modules shipped with Fedora's `ansible` package have been tested with `python3`. Locally created modules or plugins, or 3rd party community plugins, may need some adjustment to work smoothly with `python3`.
Ansible now uses Python3 by default
Automation
The `ansible` package in Fedora is switching to use *Python 3* by default, instead of *Python 2*.
This change allows you to manage target machines that don't normally ship with `python2` by default easier as well as moving `ansible` in Fedora to the Python version used by upstream to develop new features and improvements. As `python2` subpackages in Fedora are retired, more and more development will move to the `python3` versions. This change aligns the Fedora `ansible` package with that reality.
You may need to adjust what python is used on the target machines you talk to from your Fedora control host. You can do this by following the instructions in link:++http://docs.ansible.com/ansible/latest/python_3_support.html++[Ansible docs].